The browser you are currently using is not supported by gscu.org. Portions of our website and internet banking may not display or function properly when used with your current browser.
It is critical that you use the most recent version of your browser to ensure full functionality. Please click to upgrade.
Before upgrading please click here if you are utilizing Windows XP for important information.
If you believe you are receiving this message in error click here.

Electronic Check Deposits with DeposZip®

Stay out of line! There's an easier way to make your deposit.

Flash Content

Submit check deposits electronically to your credit union account. Electronic checks are treated like any other check and available for withdrawal per the credit union's regular check hold policy. You simply need a scanner and PC to get started.

Member Testimonial - click to hear what real members have to say! (MP3)

To Register
Login to OnLine Banking and select Online Deposit from the More Actions menu under whichever account you'd like to make an OnLine Deposit to. Complete the registration for your account, and we will send you a confirmation. Selecting one account will register all accounts (i.e. savings, checking, money market). Please be sure to read and accept the Remote Deposit Disclosure and Agreement.

Get Started
After you have registered, you can begin making your electronic deposits at anytime. Simply login to OnLine Banking and again select Online Deposit from the More Actions menu under whichever account you'd like to make an Online Deposit to. Easy to follow step-by-step instructions will walk you through the process.

Hardware/Software Requirements
Following are the system requirements for using DeposZip®.

Hardware:
High-Speed Internet Connection
Document Scanner (TWAIN Compliant)

Software:
Windows XP with Internet Explorer 7+, or Vista with Internet Explorer 7+
Windows XP or Vista, with Firefox 2+
Mac OS X 10.6 with Safari 3+
*Safari on Mac OS X v10.6+ must be run in 32-bit mode
Mac OS X 10.6 with Firefox 2+
Windows 7

Note: Firefox requires Java runtime environment v1.5+

Frequently Asked Questions